2

In QGIS 2.16.1's rule-based symbology as well as in its rule-based labeling, it's possible to enable a "scale range" to which the visibility of the result of the respective rule (be it a symbology style or a label style) shall be limited. However, it seems that these ranges always require both a minimum and a maximum scale.

What can I do if I want a rule to apply to all scales above a certain scale (i.e. more "zoomed in"), but not below (more "zoomed out")? The logical way would seem to be to leave out the maximum or set it to 1 : +∞ or at least to something ridiculously large like 1000000 : 1 (= 1 : 0.000001), but the QGIS UI seems to allow none of these and resets the value to the last one entered that is ≤ 1 : 1.

(And no, 1 : 1 is not the largest (most "zoomed in") scale that might occur in QGIS as you can easily verify by zooming further in on your map.)

So, is there a way to specify only a minimum scale and have a rule apply to all scales above it?

  • Is this something that has changed? From gis.stackexchange.com/q/42437/51574 I take half-open scale ranges (open in either direction) were possible back in 2012 when that question was asked. – das-g Sep 1 '16 at 8:38
  • 1
    The behaviour in that question ^ doesn't work for me, it won't allow me to delete the initial scale, simply setting it back to what it was before. That's working in version 2.14.3. – Ed Rollason Sep 1 '16 at 8:58
  • Eh, I guess it's simply a UI bug then. I'll try to report it. – das-g Sep 1 '16 at 9:38
  • bug filed as hub.qgis.org/issues/15512 – das-g Sep 1 '16 at 15:34
1

Setting the minimum value to 1:0 seems to allow you to zoom further than 1:1. I've successfully taken a dataset down to 1000:1.

It does seem to be a little bit unstable and resets itself if you tamper with the minimum scale, so set that first and then set the maximum scale.

EDIT - in fact it appears to set the GUI scale displayed back to 1:1000 every time you open the layer options but the rule still appears to work.

It appears to display correctly in the rule overview

It doesn't appear correctly when you open the dialogue

  • That's what I observe, too, except that the value snaps back as soon as the input field loses focus, so I can't ever get it to contain no value. – das-g Sep 1 '16 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.