2

I am trying to georeference a simple raster image using a world file I was supplied with, however I am struggling to associate the world file with the image. I have read up on it, it seems that in the layer properties I should be able to 'edit' the spatial reference and I cannot. I have also specified in ArcMap options 'Use world file to define the coordinates of raster'. I am using ArcMap 10.4, I don't know if this will have made a difference.

Steps: 1) Checked the file names are the same (aside from the extension) Step 1 2) Customise - ArcMap Options - Raste Dataset - Check 'use word file to define Step 2 the coordinates of the raster' 3) Load Raster Step 3 -Load Step 3 - Raster

What next?

Here is the contents of the PRJ and JGW files: Files

  • Can you provide screen shots of what you have tried thus far to perhaps better assist in answering you questions? – whyzar Jan 3 '17 at 13:57
  • Done, I've edited the post. – AJIKenyon Jan 3 '17 at 15:05
  • Looks like your .PRJ file isn't formatted properly. See this question: gis.stackexchange.com/questions/114835/…. – Dan C Jan 3 '17 at 15:46
2

The .prj file you have is in the old ArcInfo Workstation format. It was originally used for GRID files, coverages, and TINs. It's not used in ArcGIS any more, and definitely not for any non-GRID rasters. So even if you switched the information in the .prj file, the software still wouldn't pick it up.

Use the Define Projection Tool or ArcCatalog, raster properties to set the coordinate system to 27700 or "British National Grid".

Note: the world file is providing the georeferencing. That's converting the raster from raw pixel numbers to projected coordinates and extents. However, the software still doesn't know what those coordinate values mean.

1

the world file must have the same name as the image, with an extension that is derived from the data type (e.g. tfw for tif, jgw for jpeg etc). Note that the "Use world file to define the coordinates of raster" must be activated BEFORE you add the raster to the data frame.

Note that the worldfile provides the information to convert from the image coordinates (lines/columns) to the map coordinates (X/Y or lat/long), but not the coordinate system. You must also specify the coordinate system, which is maybe provided in the osgb.prj file.

EDIT: Based on the .prj file that you provided, it seems that your issue is due to the prj and not to the jgw. You can download a correct prj file from here and then use the define projection tools to import the information from your prj (or search for it in the ArcGIS predefined projections).

  • Yes I had already done this, however I don't know the next step. I have loaded in the raster. – AJIKenyon Jan 3 '17 at 14:57
  • As a kind remark, you shouldn't accept an answer if it didn't solve your problem, otherwise your problem is considered to be solved. Maybe this is the case, but your comment says the opposite. If you like an answer but it didn't solve your problem, you can upvote it with the top arrow (and remove the accepted answer flag). – radouxju Jan 3 '17 at 15:01
  • try a blank mxd. set the option to use world file then add your image and set the projection of the data frame to the projection of your image. Does it look OK then ? – radouxju Jan 3 '17 at 15:04
  • I'm new to this i'm sure you can tell! – AJIKenyon Jan 3 '17 at 15:06
  • Yes it looks fine, however it is at a scale of 1:272989210 which is most definitely wrong, the area i'm looking at is a small section of Swindon town centre. – AJIKenyon Jan 3 '17 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.