1

I am trying to organize my files by creating geodatabase and importing shapefiles into it. I have created a feature dataset for my vectors which includes a few polygon layers, a line layer and points collected with a GPS. Before importing the files I have projected all of them to Ky state plane. Except point data everything looks fine. point data was collected originally with WGS84. I do not know if it was the reason. My point data missing table and when I try to load features on it I get this error. Any idea why?enter image description here

Warning 594 says

Description These specific input features require attention. This often occurs when features are positioned outside the current XY Domain environment. The XY Domain environment sets the allowable coordinate range for x,y coordinates. If a feature falls outside this range, it cannot be added to the output. In addition, with some tools such as Append, which have a target dataset, if the features of the input fall outside the XY Domain of the target, they also will not be added. Similarly, the M Domain and Z Domain limit the coordinate range for m- and z-coordinates.

Solution Check the XY Domain, M Domain, and Z Domain environments, and reset them to Same as Input' if they are too restrictive for your inputs. When using a tool like Append, check the coordinate system of the target dataset, and if unknown, define a coordinate system for the feature class. Also, consider creating a new feature class with a broader x,y domain if the current x,y domain is too restrictive.

I have checked domain it looks like the points within the boundary.

  • 1
    Please remember to include the exact error message(s) as text within the question body. Since the error reports issues with the domain, you should include what the target domain is, and what the spatial reference and bounding envelope for the source layer contain. – Vince Nov 15 '17 at 20:36
  • 1
    Did you use the Define Projection tool or the data's property page in ArcCatalog to assign the KY state plane coordsys to the points? If so, re-assign 4326 / WGS 1984 to the points and re-import them to the feature dataset. – mkennedy Nov 16 '17 at 1:08
  • Thanks for your comments/answers. I have solved the problem. – Amadeus Nov 16 '17 at 3:02
1
  1. Create a new feature class with wgs84 in the Geodatabase (See this link).Just set Point type and projected system. Accept another options by default.
  2. Copy all of the features in the point feature class to the new feature class.

    Just start edit with editor toolbar => select all features from the source => copy selected features => paste in the new feature class. Another solutions like "Append" or "load data" can be used to import features.

  • Thank you! your answer gave me really good idea to solve the question. – Amadeus Nov 16 '17 at 3:51
0

based on @wetland answer I figured out the answer. I have created an empty feature class in feature dataset. I adjusted feature type as point and coordinate system as ky state plane then I load the points from shapefile (ky state plane). Then it worked. @wetland s answer just worked as fine but my original purpose was creating feature dataset to organize my vector data. I believe all feature classes should be in the same coordinate system in a feature dataset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.