I installed QGIS version 1.7.4 a few months ago. Under the menu Vector > Data Management Tools I have two options to make a join: 'Join Attributes' and 'Join attributes by location' (see screenshot).

enter image description here

My colleague installed the same version a couple of weeks ago. In here version, the option 'Join attributes' is missing. Today I installed QGIS 1.7.4 on some computers in a classroom and the same option was missing.

It is a handy tool to join a shapefile with a DBF, instead of doing it through Layer properties > tab Joins. Can I find it somewhere else?

  • Which version of fTools are you using? 0.5.10 has the 'Join by Attributes' – Mapperz Jun 6 '12 at 20:45
  • On my laptop I have the version you mentioned. I thought the latest version of fTools would be integrated in the installation. I'll check it on the other computers. Thanks for the suggestion. – PieterB Jun 6 '12 at 20:59
  • Yes, it is still missing in v1.8 on Windows. I can't do a join via the Layer Properties either, as there is no where to add a non-spatial .csv or .dbf table. – user12450 Nov 2 '12 at 16:26

you can reintall the ftools plugin. after that, go to "plugin" menu, then select "Manage Plugin..." from the "QGIS Plugin Manager" dialog click the "clear all" then click "select all" to refresh all plugins intalled. then click "Ok" to close the dialog. then see what happen to your "Vector" menu (Data Management Tools)... i have also experienced same of your problem. all i have to do is to refresh all my plugins intalled. i dont know, how to explain it...

| improve this answer | |
  • I tried it out and reinstalling worked fine. – PieterB Jun 27 '12 at 7:12

You can access a table join by going to the shapefile Properties (right click - Properties). On the top of the window you will see a Joins Tab. In this tab there is a plus (+) sign which will allow you to join a table.

| improve this answer | |
  • Yes, I know that possibility. But it is strange to me that in the same version of qgis, there is a difference in the 'core' tools under the menu Vector > Database Management Tools. – PieterB Jun 6 '12 at 20:44
  • I agree. I had the same thing. I have also noticed that between versions and installs not all plugins are available for download through the Fetch Installer. – Ryan Garnett Jun 6 '12 at 22:22

The 'Join attributes' tool is missing in version 0.6.2 (installed by default with qgis 1.8, at least on Linux platform).

The solution for me was to downgrade the plugin to 0.6.1 using the Python Plugin Manager.

| improve this answer | |
  • in the new release (on windows) is the 'join attributes' still missing. I hope this will be fixed in an upgrade version. – PieterB Jun 27 '12 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.