2

I imported a PNG file into QGIS for georeferencing, and set it to add automatically to map after finishing the process. However, once its job was done and the new layer and joined my list panel on the map, I couldn't see it displayed (all white background still remains).

What could the issue here potentially be? I have checked all its display and opacity settings, so I know the issue isn't there. I opened up the TIF file itself and it was all clear and available there. I've even done this process and gotten through it before, so the georeferencing part on my end shouldn't be the issue. What has gone wrong here, the projection itself, or could the file size be too big? It hasn't loaded for an entire hour already.

enter image description here

10
  • 1
    Did you choose a fitting CRS? What happens when you zoom to your image? How large is the referenced image?
    – Erik
    Jan 28, 2021 at 11:21
  • @Erik yes, and i have tried changing the project's own projection to that of the georeferenced raster layer, to no avail. The image itself was around 400 MB and the modified version approximately 1.5 GB.
    – Anna
    Jan 28, 2021 at 11:27
  • What happens when you zoom to your image?
    – Erik
    Jan 28, 2021 at 11:30
  • Has an output image been saved? Go to the folder and add the image manually (drag and drop) to QGIS.
    – Babel
    Jan 28, 2021 at 11:30
  • Adding a screenshot of your Transformation settings/Georeference dialog window could be helpful.
    – Babel
    Jan 28, 2021 at 11:32

2 Answers 2

1

The short answer: you must set the correct CRS: in your case probably EPSG:3857 (instead of 4326).

The details: The problem is that you set the CRS for output to be 4326 - a CRS with geographic coordinates. However, when you set your GCP points, you probably get the coordinates form a basemap in CRS 3857 like OpenStreetMap, Google or else. So the coordinate values you introduce are in 3857, see screenshot (with the map taken form your screenshot): The last line is the control point for Ljubliana, the coordinates are 1609680 / 5791430:

enter image description here

If you now assign CRS EPSG:4326, these coordinates are interpreted as lat/lon coordinates and are way off of the extent of +/-90 degrees N/S and +/-180 degrees E/W (see here for more information about setting CRS. If I create an output like this, I have the same problem as you: the distorte map does not show. I have to change the CRS to the CRS used for assigning coordinates to the raster. As mentioned, most webmaps are in WebMercator (EPSG:3857), so probably you should use this one:

enter image description here

7
  • Do I need to set the raster coordinate system in layer properties: source to 4326? Or is it this one, set source coordinate reference system? In the automatically opened pop-up dialogue, I get the notification that "specific crs for layer raster" by the way, and to change it for selecting an "coordinate reference system selector". Otherwise, must I change the setting for it to the one within "transformation settings" under transformation paramaters, wherein type and target crs must get to be further altered then?
    – Anna
    Jan 29, 2021 at 17:37
  • You should set the CRS in the Georeference dialog window only, not in the layer properties. In the Georeferencer, if the coordinates you introduce are lat/long (if you fill them manually, like: 46° N, 14° E), than set it to 4326. If you take the coordinates from a basemap, probably it's 3857 (coordinates like 1609680 / 5791430), see: i.stack.imgur.com/g3dtC.jpg. Normally, you should not set the coordinate system in layer properties, QGIS recognizes it automatically and manual changes in most cases result in a projection error (as described in the linked answer).
    – Babel
    Jan 29, 2021 at 18:04
  • If you take the coordinates for your control points with the function From Map Canvas, than QGIS uses the CRS you defined as project CRS (not layer CRS) - you find it at the bottom right in the QGIS main window, see: i.stack.imgur.com/B0fZC.jpg
    – Babel
    Jan 29, 2021 at 18:10
  • Allow me to clarify: yes, I know what the project settings use. However, the layer CRS for the modified, georeferenced TIF file is a user-generated custom projection. As you suggested, the online basemap is in 3857 but the actual shapefiles I am manipulating with are set to 4326. The project settings itself are 4326 as well, but the current view mode (which I always use) is in 3857 instead.
    – Anna
    Jan 29, 2021 at 18:36
  • Furthermore, I am asking about the georeference dialogue window specifically. See attached screenshots in chat for further information, please.
    – Anna
    Jan 29, 2021 at 18:37
0

In one of my case the PDF raster i used, it was not appearing on the georefrencer panel due to the size of the pdf. the actual size of the map was very small in the centre and the pdf file was big enough all around the actual map. later it worked. hope you have a pleasant way to get the raster on the georefrencer panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.