1

I am trying to add a vector shapefile to QGIS V 3.16 and am receiving an error message "Not a valid or recognized data source". There is nothing wrong with the file connection on my end as far as I can see and I have all the correct elements (shp, dbf, shx) in the folder. I have tried with and without the .inf file and tried to do a zip file and nothing is working. Does anyone know how I might troubleshoot?

I created the shapefile in pathfinder from trimble data collection

Files here: https://drive.google.com/drive/folders/19jwy79-CPG1Fqouj5V8kfhDuBGjZNp5g?usp=sharing

6
  • Ask the provider to check, whether the data is faulty or not.
    – Erik
    Dec 17, 2021 at 14:10
  • Probably the error already occured when you created the shapefile. Normally, the shp file (containing the actual data) is the largest of all, but in this case, it is not. Check out your original data source.
    – Babel
    Dec 17, 2021 at 14:11
  • Thank you! It should be bigger than the dbf? I'll check with the source. Dec 17, 2021 at 14:52
  • It may be bigger but it depends on the data. Shp stores the geometries, dbf stores the attributes.
    – user30184
    Dec 17, 2021 at 15:12
  • Yep it definitely is corrupted, specifically I think the DBF file is corrupted - opening it in a text editor just shows a whole lot of NULLs and not a single bit of actual data (which is not expected). Opening it in a hex editor shows 00s everywhere so there is just nothing in the file
    – she_weeds
    Dec 18, 2021 at 2:56

1 Answer 1

1

GDAL does not open the file but it does not show any error messages. OpenJUMP gives an error Negative Array Size Exception. ArcGIS Pro behaves like GDAL, no messages. It seems that your shapefile is definitely corrupted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.