2

I've got a shapefile with 300+ points in it, and am trying to organise the labelling.

I installed a trial version of the Maplex licence, as via some research I've come to the conclusion that this will give me many more options in terms of placement and conflict resolution, as I can't seem to get the desired effect with the standard labelling engine.

However, when I enable the maplex label engine, all my labels disappear, and I can't figure out how to get them back on? I get all the maplex options in terms of placement, but find it odd that I can't see a single label no matter what I click? I'm hoping there's a checkbox somewhere or extra step I have to perform before this will work, can anyone shed any light on this?

My labels are all showing fine using the standard labelling editor (though they all overlap, and I want to be able to fix them without converting to annotation and placing each individually, as there are so many!) But as soon as I enable Maplex, they disappear.

[EDIT: Screengrabs added: Prior to enabling Maplex, I can see every point labelled: Prior to enabling Maplex

Then when I hit Enable Maplex, they all disappear? Maplex Enabled

Hitting View Unplaced Labels doesn't change anything? View Unplaced Labels

And even when I make sure Never Remove Labels is ticked, I still can't see any labels? Never Remove Labels

Is there really a scale limit to labelling? This is not the actual file I was trying to label initially, but the same thing is happening to every file I have?

[EDIT: On further research, I've noted a similar problem on another Stackexchange post here, with a variety of suggestions, all viable but also not working for me. Not sure if it's reassuring that it's maybe not just me, or disconcerting!]

[EDIT: On contacting Esri Tech Support about this: "In general, we support installation and evaluation issues with trial ArcGIS features, but ArcGIS 9.2 has been retired for over 18 months and we no longer support this version of our product."

...I would guess that this means it's probably a compatibility issue with 9.2 and maplex rather than a standalone maplex issue, as I've just tried a single point at 1:250 scale with 72pt size labelling and again, works prior to enabling maplex but disappears after. Thanks for all comments and suggestions.]

  • Are you really using ArcGIS Desktop 9.2? 10.2 seems more likely for a trial version. – PolyGeo Nov 28 '13 at 20:11
  • Yes, I've got a full licence for ArcGIS Desktop 9.2, it's just the Maplex extension I've enabled the trial for, sorry, should have been more explicit with that! – Lisa SH Nov 29 '13 at 11:52
  • 2
    You know that Maplex is a free extension to ArcGIS 10.1 at all license levels. proceedings.esri.com/library/userconf/devsummit12/papers/… – Mapperz Nov 29 '13 at 17:36
  • I didn't actually know that, thanks for that info! Pushing for an upgrade anyway so maybe Maplex will be the swinger... if I can get it to work! – Lisa SH Dec 16 '13 at 16:48
  • Do they appear at different scales? Try zooming in – GISKid Dec 16 '13 at 17:51
2

With ArcGIS Maplex Label Engine

Switch on the View Unplaced Labels but clicking the icon on enter image description here the toolbar.

Displays the labels that could not be placed on the map

http://resources.arcgis.com/en/help/main/10.1/index.html#//00s800000054000000

There maybe a more settings that are causing the labels not to be placed. See http://resources.arcgis.com/en/help/main/10.1/index.html#//00s800000071000000 for reference

Forcing all labels to display this is the last resort Check the Never remove (place overlapping) check box.

Click the Label Manager button Label Manager on the Labeling toolbar.

Check the check box next to the layer you want to label.

Choose a label class under the layer.

Click the Properties button.

Click the Conflict Resolution tab.

Check the Never remove (place overlapping) check box.

http://resources.arcgis.com/en/help/main/10.1/index.html#/Forcing_the_placement_of_all_labels_in_a_label_class/00s800000041000000/

(There should be no difference in the Maplex Labeling Engine in 9.2 and 10.1)

  • Thanks for your input, however neither View Unplaced Labels nor the Never remove label checkbox is making a difference unfortunately!! - none of my labels appear on the map whenever Maplex is enabled, regardless of these settings? (I've also tried different shapefiles and different map documents to check it's not a bug in the file, but I can't get a single label to go on). – Lisa SH Nov 29 '13 at 17:21
  • 1
    Can you do some screenshots - if your data is below a large scale 1:500 with large point size text it will never show. I remember from a project many years ago had this issue. – Mapperz Nov 29 '13 at 17:38
  • Ah I didn't realise there was a scale limit - the data is at 1:40,000! Does this mean it will basically never show? I'll add some screengrabs today if this is useful. – Lisa SH Dec 2 '13 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.