1

QGIS 2.18.12 - When I use the Clip or Merge Shapefile tools in QGIS, the set of Shapefiles is created with my chosen name and in the folder I have designated. However, in the Layers Panel, the layer is shown as 'Clipped' or 'Merged'. Is there a good reason for this? Wouldn't it be clearer if the Shapefile name was shown instead? It can be confusing if I have more than one clipped or merged layer.

marked as duplicate by ahmadhanb, ArMoraer, mgri, Oto Kaláb, gisnside Sep 13 '17 at 12:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Should have said 'Layers Panel' in heading. – Bill C Sep 12 '17 at 22:13
  • Please Edit your question instead of commenting on it. – Vince Sep 13 '17 at 2:08
4

Under "Processing" menu -> "Options" look for the "Use filename as layer name" option (under 'General' settings):

enter image description here

Tick that on and you'll get the behavior you desire.

Not the answer you're looking for? Browse other questions tagged or ask your own question.