1

I am having issues clipping a very large polygon shapefile.

Can you all help me?

The error returned is “WARNING 000117: Warning empty output generated“. I have tried troubleshooting all of the usual suspects, including recommendations from the stackexchange community such as:

  1. The polygons are in the same projection
  2. I repaired the geometry (which fixed some issues but still got the error message when re-running)
  3. Since it is a large file – I created a new shapefile of subset data (Export data) that was much smaller and it is still not working
  4. The clip feature is just one single polygon not a multipart polygon
  5. The clip feature is contained within the shapefile of polygons that I am trying to clip (ie clip feature is for a small area in Central America and the polygons that I am trying to clip are for the entire world)
  6. Both are shapefiles as I know geodatabases can sometimes cause issues
  7. I have used the clip feature with other shapefiles without a problem so I know that nothing is wrong with this clip feature.
  8. Standard re-boot of computer, programs
  9. No features are selected when I am running this tool
  10. Located in a folder with no spaces and the file name is very short

However the clip still returns the same error. The large dataset I am trying to clip is the MAMMALS file located at this link (the amphibians and reptiles files work just fine, but the Mammals does not): http://www.iucnredlist.org/technical-documents/spatial-data

  • If you're performing the clip in ArcMap do you have a selection in either layer? (even an empty selection). You've addressed all the common problems which shortens the list of things that could be the cause. – Michael Stimson May 24 '18 at 22:32
  • No, no selection in either layer. I also tried this in ArcCatalog and ArcMap just in case. Yes, I addressed all of the common problems which is why I am at such a loss. Any help would be greatly appreciated as I have no idea how to move forward. – Amy J. May 30 '18 at 16:03
  • Did you repair geometry on the clip feature class? Or is it that your clip is a selection of the whole? That would simplify CRS differences.. Is there any chance you can Zip and upload the source and clip to Google drive or DropBox? Assuming it's not proprietary or sensitive information, I don't want to cause legal problems for you but I'd really like to see the data. – Michael Stimson May 30 '18 at 22:23
  • Thanks Michael. The data is actually located online, as I mentioned above. Yes, I did repair the geometry. I finally was able to get something to work after a lot of trials.... – Amy J. May 31 '18 at 20:28
1

After a lot of trials, I finally found that the following procedure works:

  1. Download Terrestrial Mammals and Marine Mammals separately

  2. Repair Geometry (as I had done before)

  3. Select by location (so this selected only the polygons that were located in the area that I wanted to clip it to)

  4. Export selected data into a new shapefile

  5. Split by Attribute Plug In (https://www.umesc.usgs.gov/management/dss/split_by_attribute_tool.html) which split each polygon in the shapefile into a different feature class of a new geodatabase

  6. Clip using Model Builder's feature class iterator

And so far, it has been working!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.