I am trying to use the new heatmap plugin to create a heatmap from about 10k points. When I enter the parameters and start the process , QGIS becomes unresponsive. I don't get a progress bar or a dialog. If I let it be, it generates the heatmap after an hour or so. On the same system, GRASS's v.kernel creates the heatmap in under a minute. I tried with a few different parameters and reducing number of points but it isn't much better. What am I doing wrong? Have others seen such behavior? I am using QGIS 1.8 on Windows 7.

The data I am trying to work with is at http://data.london.gov.uk/datastore/package/policeuk-crime-data

1 Answer 1


Heatmap plugin has been greatly improved between 1.7.x and 1.8. If you find that using the same settings in GRASS is many times faster, please report this issue.

Make sure the output raster size and other settings are as similar/same as possible. I'll try to test too.

Old: Unfortunately, the heatmap plugin - as it is currently implemented - is not very good. I'd definitely recommend using GRASS as you already did.

To me, the plugin is more a proof of concept than a production worthy tool. Adding a rating system to the plugin installer would enable users to better judge the quality of a given plugin.

  • Thank you. I was under impression that since it's a core plugin, performance would be quite good. An app store like model for the plugins would be nice. Jul 12, 2012 at 14:33
  • Oh, I wasn't aware that the Heatmap plugin has been severely updated for 1.8 release. It looks much better than last time I tried it. Please fill a bug report if you think it's suspiciously slow with the same settings working well in GRASS.
    – underdark
    Jul 14, 2012 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.