3

After reinstalling QGIS, the desktop program runs but generates the python error "Couldn't load SIP Module Pythin support will be disabled"

Because of this error, no plug-ins will load. I found a couple of descriptions of a similar problem on-line, which recommended:

sudo apt-get install python-sip4 sudo apt-get install python-qt4

Neither of these worked, and in fact neither even returned an installation candidate. Note that the error reports that recommended these were at least 1 year old, or older.

I installed SIP from this source http://www.riverbankcomputing.com/software/sip/download and confirmed its installation, but QGIS continues to generate the same error.

System details:

OS: Xubuntu 12.04 with Xcfe desktop QGIS: 1.8 Python: 2.7.3 SIP: 4.13.3

Any help would be greatly appreciated.

1

If you had an older QGIS installed and working, then try moving the old .qgis folder aside (mv .qgis .qgis_old) and try again.

1

I most commonly get this error when starting QGIS if I'm running qgis from a terminal that has a Python virtualenv activated. (In particular, if it's a virtualenv set up with --no-site-packages, but that has been the default for some time so is almost always the case for me.) That means that it won't find the system installed Python packages that are installed as dependencies by apt-get.

The solution for me is to start QGIS from a new shell, when there should be no active virtualenv.

(I suspect this is not the problem that the original questioner was having 6 years ago, but it may well be useful to other people searching for the problem, and this seems like the best question to add this answer to!)

1

Updating python modules crashes QGIS in most cases. It is a kind of heart transplantation: Don't do it unless you know exactly what you are doing.

You should use the same Python version that QGIS is built against.

So remove your SIP installation, and take the SIP version from your Ubuntu repo.

  • Hi Andre, I have QGis 3.4.2-Madeira, Python 3.6.7, Sip 4.9.12 and QT 5.1.1 and Lubuntu 18.10. What the SIP version from your Ubuntu repo? Thanx – ilFonta Dec 21 '18 at 10:17
  • I'm still on bionic, but QT5.1.1 looks rather old? I have python3-sip 4.19.7 – AndreJ Dec 21 '18 at 13:32
  • Do you suggest me to install the latest QT versions? – ilFonta Dec 21 '18 at 14:17
  • You shuld have the default QT version from your ubuntu repo. According to packages.ubuntu.com/… it should be 5.11.1. – AndreJ Dec 21 '18 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.